Lag on Mobile makes the site innoperable

Discussion in 'Site Feedback and Support' started by Judoka, Feb 22, 2017.

  1. ChrisMWilliams

    ChrisMWilliams Publisher
    Staff Member Bookie

    Apr 10, 2006
    19,726
    2,223
    113
    Male
    Hack Blogger
    Bondurant, Iowa
    Guys let me know how the site is acting for you now on the mobile. I made a few tweaks for mobile only stuff.

    Going to be a process but what I just did should help.
     
    • Like Like x 1
  2. Gunnerclone

    Gunnerclone Well-Known Member

    Jul 16, 2010
    18,727
    1,439
    113
    Cheddar Production
    DSM
    Better today.
     
  3. JBone84

    JBone84 Well-Known Member

    Nov 30, 2006
    1,655
    49
    48
    Male
    Mechanical Engineer
    Rochester, MN
    I don't know if it was just the placebo effect, but it seems better this afternoon.
     
    • Winner Winner x 1
  4. cydsho

    cydsho Active Member

    Apr 10, 2006
    969
    96
    28
    Omaha, NE
    I have android and have cleared my cache but it immediately failed to load still.
    My Chromebook seemed to be working quite a bit better but then it locked up everything and did a hard reboot.
     
  5. ChrisMWilliams

    ChrisMWilliams Publisher
    Staff Member Bookie

    Apr 10, 2006
    19,726
    2,223
    113
    Male
    Hack Blogger
    Bondurant, Iowa
    Just to be clear I haven't made any changes to tablet/desktop viewing. Just for phones right now. Trying to solve one problem at a time.
     
    • Like Like x 2
  6. Gunnerclone

    Gunnerclone Well-Known Member

    Jul 16, 2010
    18,727
    1,439
    113
    Cheddar Production
    DSM
    Now it's bad again.

    The most annoying thing is that loading pages pauses any active audio playing
     
  7. k123

    k123 Active Member

    Sep 14, 2011
    476
    88
    28
    Engineer
    Iowa
    I've had a lot of lag on the desktop on PC. Seems a little better this afternoon.
     
  8. jbhtexas

    jbhtexas Well-Known Member

    Oct 20, 2006
    12,250
    534
    113
    Male
    Arlington, TX
    #68 jbhtexas, Feb 22, 2017
    Last edited: Feb 22, 2017
    No improvement for me on my android 4.3 phone. The page partially loads and just freezes for a couple of minutes, and then finally fully loads. It doesn't matter what browser I use.

    The site works fine on my android 5.1 tablet.

    This is not a new problem. There have been several threads on it, and I think in one of the threads, if I remember correctly, the problem was tracked to video ads???

    I've found that if I kill the page load a few seconds after some of the page content shows up and the page load freezes, it seems that most of the useful things have actually loaded on the page.
     
  9. stormchaser2014

    stormchaser2014 Well-Known Member

    Mar 12, 2012
    12,702
    1,140
    113
    Wisconsin
    Hard to tell right now, sometimes it's fast sometimes it's not. Right now typing is really fast, but the page is still loading.
     
    • Agree Agree x 1
  10. flynnhicks03

    flynnhicks03 Well-Known Member

    Apr 11, 2006
    1,945
    177
    63
    Damn it, we want tons of great content, extremely fast performance, no ads and we want it all for free!
     
  11. ChrisMWilliams

    ChrisMWilliams Publisher
    Staff Member Bookie

    Apr 10, 2006
    19,726
    2,223
    113
    Male
    Hack Blogger
    Bondurant, Iowa
    I have removed a ton of ads from the site. Hopefully stuff improves across the board. I still have other stuff I'm gonna do. Gotta go do radio and Ill work more on this later tonight.
     
    • Friendly Friendly x 2
    • Like Like x 1
    • Winner Winner x 1
  12. Skyh13

    Skyh13 Well-Known Member

    Mar 17, 2006
    4,016
    112
    63
    I haven't checked today, but the experience on mobile ever since the redesign has been terrible, generally unusable. I just hadn't complained about it until somebody woke up the thread saying it was laggy and I decided to finally say something.

    I've always been on android, and it hasn't mattered what version or what browser. Chrome, firefox, built-in android browser, it's always really, really bad.

    I'll add in that even browsing on a desktop computer is often laggy. I feel like this experience isn't usual, even with other sites that are ad-heavy.. so I wonder if it's less the existence of the ads, and more an implementation issue somewhere. I wish I could offer more in terms of looking into it, but I don't have experience with implementing ad systems in websites. I'm not sure if it's typical for sites with ads to be constantly making a crap ton of web calls downloading content, which appears to be the case when I monitor the network activity through Chrome's developer console. There's also a lot of warnings and errors when loading stuff in the console. Perhaps the developer can monitor some of that stuff and try to either update the ad systems to fix any bugs on their end, or make sure all the necessary scripts are in place, I dunno.
     
    • Agree Agree x 1
    • Informative Informative x 1
  13. Clone83

    Clone83 Well-Known Member

    Mar 25, 2006
    4,183
    181
    63
    I got an iPhone 6s about the time of the new design. Before that my android was ancient and this site pretty much unusable, prinarily due to my phone.

    With the iPhone it has been pretty good, and I don't use an ad blocker with Safari.

    What it often does with the iPhone though, is suddenly reload, I'm pretty sure due to the ads. It is annoying in writing posts in that that typically means the loss of your post. In any very long I try to copy as I go, in case this happens (and the longer the post the greater the time to compose and the likelihood of it happening). If it happens to a relatively long post and I lose it all, it is likely I won't even try to rewrite it.

    The safest thing to do is to write it in Google docs and copy it over, but you are still losing some of the functionality and ease of use, even with the iPhone 6s (and no ad blocker).

    The new design remembers what you have composed at some point, which is good, but what I am talking about is just getting on going to post something and suddenly it is gone and that time wasted.

    Anyway the experience for me is generally pretty good but that is still an issue.
     
  14. Dopey

    Dopey Well-Known Member

    Nov 2, 2009
    1,630
    104
    63
    The entire CF support staff must be apple fan boys.

    My Apple work phone is fine. My personal Android phone is terrible.

    This has been the case since day 1 on this new site. Also, I don't feel it's the ads. Your for pay site won't help this.
     
    • Agree Agree x 1
  15. Pat

    Pat Active Member

    Oct 20, 2011
    308
    53
    28
    Yeah, I'm on an iPhone 6s with Safari and no ad-blocker and have never had lag issues. @ChrisMWilliams I'm wondering if iOS's refusal to play nice with Flash is the reason it works so well - that seems to be the common theme here.

    I *love* the mobile site. So there.
     
    • Agree Agree x 3
  16. Acylum

    Acylum Well-Known Member

    Nov 18, 2006
    3,722
    237
    63
    Fed Govt
    Parts Unknown
    Took the advice in this thread and downloaded something called NeverAds for my iphone 6 and now the mobile site is much improved for me. Posting from my work Dell laptop and the full site is still no bueno though.
     
  17. Dopey

    Dopey Well-Known Member

    Nov 2, 2009
    1,630
    104
    63
    I would bet large sums of money that this is the issue.

    Large large sums.
     
    • Agree Agree x 1
  18. AgronAlum

    AgronAlum Active Member

    Jul 12, 2014
    793
    185
    43
    I'm right there with ya. I don't use ad blocker (iPhone 6 and chrome) and rarely have had an issue. Normal pages take about 2 seconds to load on wifi and cell. Occasionally when going to a first new post it'll kick me back up to the post again after a few seconds.

    Now that you're done giving out Walmart gift cards I'm happy with the site.
     
    • Agree Agree x 1
  19. BoxsterCy

    BoxsterCy Well-Known Member

    Sep 14, 2009
    17,931
    2,567
    113
    Living the Dream
    Minnesota
    Any news on our free IPhones? ;)
     
  20. agardini

    agardini Member

    Nov 12, 2009
    287
    5
    18
    I know that you said you only did things to the mobile site, but on my laptop I can at least load the pages now. I am not getting the error anymore that I had posted earlier. It now just lags on each page for a little bit.
     

Share This Page