Tried to do a search from Tapatalk and got an error saying the website's Tapatalk plugin is out of date.
Also, and this may be a Tapatalk issue, when I tried to post in this forum I got an error saying I need to select a thread prefix, but there's no way to do that within Tapatalk.